Rename all "iterator" parameters to "callback"
Reported by Joe Gornick | February 13th, 2009 @ 03:53 PM
The term iterator is used incorrectly as a parameter in methods that are used to iterator over a collection. Instead, we should rename the iterator parameter to callback.
ECMA-262 uses callbackFn
PHP uses callback
Ruby uses blocks
.NET uses predicate for functions that return true or false
.NET also uses func or different names depending on the context of the callback
Comments and changes to this ticket
-
John-David Dalton February 18th, 2009 @ 11:47 PM
- State changed from new to resolved
Please Sign in or create a free account to add a new ticket.
With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.
Create your profile
Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป
JavaScript frameworks share similar features and functionality such as DOM manipulation, event registration, and CSS selector engines. FuseJS attempts to incorporate the strengths of these frameworks into one stable, efficient, and optimized core JavaScript framework.